четверг, 28 марта 2013 г.

Суммирование каждой n-й строки

Предположим в ячейках A1:A14 у нас находятся некоторые числа и мы хотим просуммировать, например, только нечетные строки. Тогда проще всего воспользоваться следующей формулой:

=СУММПРОИЗВ(A1:A14;ОСТАТ(СТРОКА(A1:A14);2))

а для суммирования только четных такой:

=СУММПРОИЗВ(A1:A14;ОСТАТ(СТРОКА(A1:A14)+1;2))

Но чтобы просуммировать, например, каждую пятую строку нашу формулу придется усложнить.