четверг, 27 сентября 2012 г.

Функция Капрекара

Возьмем число в котором не все цифры одинаковые.

Составим два новых: наибольшее возможное из цифр исходного числа и наименьшее возможное. Вычтем из большего меньшее.

Произведенные действия называют функцией Капрекара, названной в честь индийского математика открывшего интересное свойство числа 6174.

Применив функцию Капрекара к числу 6174 мы вновь получим число 6174. Более того, если исходное число четырехзначное, то через конечное число шагов мы придем к числу 6174.

Чтобы в Excel применить функцию Капрекара составим в ячейке B1 такую формулу (в ячейке A1 у нас исходное число):

=СУММПРОИЗВ(НАИБОЛЬШИЙ(ПСТР(A1;СТРОКА(ДВССЫЛ("1:" & ДЛСТР(A1)));1)*1;СТРОКА(ДВССЫЛ("1:" & ДЛСТР(A1))))-НАИМЕНЬШИЙ(ПСТР(A1;СТРОКА(ДВССЫЛ("1:" & ДЛСТР(A1)));1)*1;СТРОКА(ДВССЫЛ("1:" & ДЛСТР(A1))));10^(ДЛСТР(A1)-СТРОКА(ДВССЫЛ("1:" & ДЛСТР(A1) ))))

Формула содержит массивы, поэтому после окончания ввода нужно нажать CTRL+SHIFT+ENTER.

Чтобы получить следующий шаг можно просто скопировать полученную формулу в следующую ячейку и т.д.   

Похожие по тематике посты - еще почитать:

Комментариев нет:

Отправить комментарий