вторник, 19 июля 2011 г.

Определяем простое ли число с помощью формул массива

Использование массивов позволяют упростить многие вычисления.
В частности все манипуляции, описанные в статье "Является ли число простым", можно заменить одной формулой.

Пусть в ячейке A1 находится число и нужно проверить простое ли оно. Достаточно в ячейку B1 ввести такую формулу:

=ЕСЛИ(МИН(ОСТАТ(A1;СТРОКА(ДВССЫЛ("2:"&ОКРУГЛ(КОРЕНЬ(A1);)))))=0;"составное";"простое")

Можно пойти еще дальше и записать в ячейке C1 формулу:

=СУММ(--(ОСТАТ(A1;СТРОКА(ДВССЫЛ("1:"&A1)))=0))

Эта формула покажет сколько у числа в ячейке A1 делителей.
Например, для числа 12 количество делителей будет 6, а именно 1, 2, 3, 4, 6 и само число 12.


Указанные формулы используют массивы, поэтому после окончания ввода нужно нажать CTRL+SHIFT+ENTER.

пятница, 15 июля 2011 г.

Выделить пустые ячейки таблицы

Чтобы выделить пустые ячейки в Excel проще всего воспользоваться условным форматированием.
Заходим "Меню" - "Формат" - "Условное форматирование".
Дальше выбираем "значение" - "равно", пишем ="" и определяем нужный формат.



Получаем в итоге



Если таблица содержит только числа, то можно условие записать "значение" "равно" 0.

среда, 13 июля 2011 г.

Как найти ячейки, содержащие нужное слово

Пусть есть список каких-либо данных (для примера список ФИО) и требуется посчитать количество ячеек, содержащих нужное слово (напр. имя Олег).

Заходим "Меню" - "Правка" - "Найти", либо используем сочетание клавиш CTRL + F. В поле "найти" пишем "Олег" и щелкаем кнопку "Найти все". Получаем список удовлетворяющих поиску ячеек.


При этом в строке состояния поисковой формы видно общее количество найденных ячеек.
Чтобы не просто найти, но и выделить найденные ячейки переходим на вкладку "Заменить", щелкаем "Параметры". Напротив поля "заменить на" щелкаем "формат" и выбираем то, что нужно. После того, как все набрано, щелкаем "Заменить все".


Теперь все ячейки, содержащие нужную фразу, выделены.