понедельник, 22 ноября 2010 г.

Парадокс дней рождения

Парадокс дней рождения — утверждение, гласящее, что если дана группа из 23 или более человек, то вероятность того, что хотя бы у двух из них дни рождения (число и месяц) совпадут, превышает 50 %. Для группы из 60 или более человек вероятность совпадения дней рождения хотя бы у двух её членов составляет более 99 %. (подробнее на Википедии).

Доказательство приводить не будем, а в Excel смоделируем.

среда, 17 ноября 2010 г.

Число 153

  1. Возьмем ЛЮБОЕ положительное целое число.
  2. Умножим исходное число на 3. 
  3. Сложим возведенные в куб цифры полученного числа.
  4. Повторим пункт 3 с получившимся числом.
  5. Через какое-то количество итераций придем к числу 153. Всегда!
Проверим в Excel.

четверг, 11 ноября 2010 г.

Надбавка и скидка

Что если цену товара сначала увеличить на 25%, а затем уменьшить на 25%?
Решим алгебраически: (1 + 0.25)*(1 - 0.25) = 1 - 0.252, меньше 1, т.е. цена станет меньше исходной.
В общем виде (1 + x)*(1 - x) = 1 - x2.
Пригодилась формула сокращенного умножения, известная еще со средней школы.

вторник, 9 ноября 2010 г.

Фокус

Есть такой карточный фокус:
"Раскладываете карты в три стопочки рубашкой вниз и просите зрителя запомнить карту и сказать, в какой стопочке она находится. После того, как вы сдали двадцать одну карту, остальные карты отложите в сторону, потому что они не нужны для фокуса.
Спрашиваем у зрителя, в какой стопочке находится карта, и кладем эту стопочку между двумя другими. Опять раскладываем карты в три стопочки.
Снова задаем тот же вопрос и опять кладем стопочку в середину. Сдаем карты в третий раз.
Во время сдачи запоминаем четвертую карту в каждой стопочке, потому что одна из них - искомая. Теперь спрашиваем у зрителя в какой стопочке карта, и спокойно называем ее." (ссылка)

Идею оставим, а вместо карт возьмем числа.

суббота, 6 ноября 2010 г.

Нумерология. Считаем в Excel


Пишем в ячейке A1 ФИО.

Копируем в ячейку B1 такую формулу:

=СУММ(НАЙТИ(СТРОЧН(ПСТР(ПОДСТАВИТЬ(A1;" ";"");СТРОКА(ДВССЫЛ("1:"&ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))));1));"абвгдеёжзийклмнопрстуфхцчшщъыьэюя")) 

Она содержит массивы, поэтому нажимаем одновременно CTRL + SHIFT + ENTER

пятница, 5 ноября 2010 г.

Финансовые функции Excel

В предыдущей заметке была рассмотрена техническая сторона расчета кредита.

Но если практически, то запускаем Excel, там полно финансовых функций и рассчитать платеж по кредиту не проблема.

понедельник, 1 ноября 2010 г.

Кредит равными платежами

Предположим необходимо рассчитать сумму ежемесячного платежа по кредиту. Исходные данные:
K - сумма кредита
p - процентная ставка за месяц (если 17% годовых, то p = 0,17/12 = 0,01417)
n - количество выплат по кредиту (так, если 5 лет, то n = 5*12 = 60)
B - сумма ежемесячного платежа